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Introduction 

The Crystal Reports for Beginners workshop will provide you with an overview and hands on experience 

into developing Crystal Reports for your iMIS data. The workshop will use the iMIS 10.6 demo database and 

Crystal Reports version 9.0.  

 

In order to provide you with as much learning time we have split the workshop into two sessions (1) Crystal 

Reports presentation and overview and (2) hands-on exercises. We hope that this will allow you to learn 

the basics and then you can work through this handbook’s exercise at your pace.  

 

What we give you here, we hope, is enough information to either enhance any skills you may have or give 

you enough knowledge to massage existing reports or a better understanding if you want to consider 

partaking of the entire course with ASI or others.  

 

The Beginner’s workshop will cover; 

• Overview of Crystal Reports and the report design window 

• Creating a basic report  

• Record selection 

• Linking tables 

• Using Parameter fields 

• iMIS Standard Reports an overview 

 

The Advanced workshop will cover: 

• Review of basic workshop/ CR knowledge 

• Formula Basics 

• Conditional Formatting 

• Report Sections 

• Sub reports 

• Exporting report data. 

• Moving a report to Production from Test. 

• Troubleshooting 

 

We hope you enjoy the workshop!  

 

Greg Norris, REIQ  

&  

Michelle Lelempsis, Asthma Foundation NSW  
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Application Details  

Crystal Report version 9.0 
Start >> All Programs >> Crystal Reports 9 Tools >> Crystal Reports 9 

 

iMIS Login  
Database login for Crystal Reports  

Username: sa 

Password: sa 

 

iMIS client login  

Username: MANAGER 

Password: manager 

 

 

Creating a Basic Report  

Workshop 1. Creating a report 
In this exercise you will create a membership expiration date report.  

 

1. Create a new custom report by selecting File > New > Crystal Reports Gallery, select As a Blank Report, 

and click OK.  

2. On the Database Expert window, select Create New Connection and then select ODBC.  

3. Select the iMIS10 Data Source and then click Next.  

4. Enter the User ID (sa) and Password (sa) and click Finish.  

5. Expand the Database and then expand the Tables.  

6. Double-click Name in the table list and then click OK.  

7. Select View > Field Explorer to open the Field Explorer window.  

8. Expand Database Fields  

 

 
 

9. Expand the Name table and select the following fields to display on your reports ID, FULL_NAME, 

COMPANY and PAID_THRU by dragging each field into the Details section.  

10. Select Report > Refresh Report Data – The report preview should appear similar to the following 

example:  
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11. Save the report as Workshop1.rpt to a folder ‘Workshop’ on the desktop.  

 

Congratulations you have made your first Crystal Report!  

 

 

Workshop 2. Add another field and use the Format Editor 
Using the report that you created in the previous exercise we will add the FULL_ADDRESS field and enable 

Can Grow on this field.  

 

1. Add the FULL_ADDRESS field onto the report – drag the FULL_ADDRESS field from the Field Explorer 

window into the reports detail.  

2. Preview the report – notice how only part of the FULL_ADDRESS data is displaying? 

3. Right-click on the FULL_ADDRESS field and select Format Field.  

4. From the Common tab select the Can Grow option and click ok.  

 
5. Preview the report.  

6. Save the report as Workshop2.rpt 

 

 

Workshop 3. Suppress the ID field 
Using the report that you created in the previous exercise suppress the ID field from the report.  

 

1. Open the Workshop1.rpt report  

2. Right-click on the ID field and select Format Field.  

3. Form the Common Tab enable the Suppress option and click ok.  

4. Preview the report.  
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5. Save the report as Workshop3.rpt 

 

 

Reviewing the Report Design Window   

Workshop 4. Position and resize objects  
In this exercise we will move and resize objects on the report that we made in the previous exercise.  

 

1. Open the report Workshop1.rpt  

2. Resize the ID field in the Page Header and Details sections.  

3. Drag the guidelines for the LAST_FIRST, COMPANY and PAID_THRU fields to the left 

4. Resize the LAST_FIRST field in the Page Header and Details section.  

5. Resize the COMPANY field in the Page Header and Details section.  

6. Save the report as Workshop4.rpt 

 

 

Record Selection  

Workshop 5. Create a membership index report  
In this report we will create a new membership index report that displays the members ID, member type, 

name and company name based on selected criteria.  

 

1. Select File >New to open the Crystal Reports Gallery window.  

2. Select the Using the Report Wizard option and select the standard report wizard  

3. Click OK to open the Standard Report Creation Wizard window.  

4. Navigate to and select the Name table by double-clicking o it.  

5. Click NEXT to display the Fields tab.  

6. Select and add the following database fields from the Name table:- 

6.1. ID  

6.2. MEMBER_TYPE  

6.3. LAST_FIRST 

6.4. COMPANY 

6.5. CITY 

7. Click Finish  

8. Select the Design tab  

9. Right-click on the COMPANY field and select Format Field to display the Format Editor window.  

10. Enable the Can Grow option on the Common table and click OK.  

11. Click the Select Export icon on the Standard tool to display the Choose Field window  
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12. Select the MEMBER_TYPE field  

13. Click OK to display the Select Expert window.  

14. Click the drop-down list, and select is one of.  

15. Click the second drop-down list and select CM.  

16. Click the second drop-down list again, and select SCH 

 
17. Click ok and you report should be similar to the following example.  

 

 
18. Save the report as Workshop5.rpt 

 

 

Workshop 6. Adding additional selection criteria to the membership index report  
In this report we will add additional selection criteria to the membership index report that was created in 

Workshop 5.  

 

1. Open Workshop5.rpt report  

2. Select the CITY field  

3. Click the Select Expert icon on the Expert Tools toolbar.  

4. Click the drop-down list and select is equal to.  

5. Click the second field and enter Dallas.  

 
6. Click OK  

7. Click the Refresh icon on the Standard toolbar to update the data on the Preview tab. Your Report 

should appear similar to the following:  

 
 

8. Save the report as Workshop6.rpt 
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Sorting and Grouping  

Workshop 7. Sorting, Grouping and Summarising Records   
In this workshop you will create a new report to show all members sorted by member type and last name.  

 

1. Select File > New to open the Crystal Reports Gallery  

2. Select the Using the Report Wizard option, and select the Standard Report wizard 

3. Click OK to open the Standard Report Creation window.  

4. On the Data tab, navigate to and select the Name table by double-clicking on it.  

5. Click Next  

6. Insert the ID, MEMBER_TYPE, LAST_FIRST, and COMPANY database fields.  

7. Click Finish.  

8. Click the Record Sort Export icon on the Export Tools tool bar to open the Record Sort Order window.  

9. Select the Name.MEMBER_TYPE field and click the Add icon to move the field to the Sort Fields area of 

the window.  

10. Select the Name.LAST_FIRST and click the Add icon to move the field to the Sort Fields area of the 

window.  

 
 

11. Click OK  

12. Click the Refresh icon on the Standard toolbar. Your report should be similar to the following example:  

 
 

13. Save the report as Workshop7.rpt  

 

 

Workshop 8. Grouping Records  
In this workshop you will group the report results from the Workshop 7 exercise by member type.  

 

1. Open the Workshop7.rpt  

2. Click the Insert Group icon on the Insert Tools toolbar  

3. Click the first drop-down list, and select Name.MEMBER_TYPE.  
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4. Click OK  

5. Click the Refresh icon on the Standard toolbar. Your report should be similar to the following example:  

 
6. Save the report as Workshop8.rpt 

 

 

Workshop 9. Grouping Records in specified order  
In this workshop you will group the report results from the Workshop 7 exercise by member type.  

 

1. Select File > New to open the Crystal Reports Gallery  

2. Select the Using the Report Wizard option, and select the Standard Report wizard 

3. Click OK to open the Standard Report Creation window.  

4. On the Data tab, navigate to and select the Name table by double-clicking on it.  

5. Click Next  

6. Insert the ID, MEMBER_TYPE, LAST_FIRST, COMPANY and STATE_PROVINCE database fields.  

7. Click Finish.  

8. Click the Record Sort Expert icon on the Export Tools toolbar to open the Record Sort Order window.  

9. Select the Name.MEMBER_TYPE field and click the Add icon to move the field to the Sort Fields area of 

the window.  

10. Select the Name.LAST_FIRST field and click the Add icon to move the field to the Sort Fields are of the 

window.  

11. Click OK  

12. Click the Insert Group icon on the Insert Tools toolbar  

13. Click the first drop-down list and select Name.MEMBER_TYPE  

14. Click OK  

15. Click the Insert Group icon on the Insert Tools Toolbar 

16. Click the first drop-down list and select Name.STATE_PROVINCE  

17. Click the second drop-down list and select in specified order. The Specified Order tab will display :  
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18. Enter North in the Named Group field on the Specified Order tab.  

19. Click New on the Specified Order tab to display the Define Named Group window.  

 
 

20. Select is one of from the drop-down list. A second drop-down list that pulls from the 

Name.STATE_PROVINCE field and an empty text are will display.  

21. Select each of the northern states from the second drop-down list to add them to the text area. The 

text area expands to a third drop-down list.  

22. Click OK  

23. Enter South in the Named Group field on the Specified Order tab.  

24. Click New on the Specified Order tab to display the Define Named Group window.  

25. Select is one of from the drop-down list.  

26. Select each of the southern states from the second drop-down list to add them to the text area.  

 
  

27. Click OK  

28. Select the Others tab  

29. Enable the Put all others together with the name option and enter others in the empty field.  

 
 

30. Click OK   

31. Click the Refresh icon on the Standard toolbar. Your report should be similar to the following example:  
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32. Save the report as Workshop9.rpt 

 

 

Linking Tables  

Workshop 10. Linking Tables - I 
In this workshop you will create special badges for an upcoming event. The badges need to include the 

member’s informal name, full name, title, company, city and state.  

 

1. Select File > New to open the Crystal Reports Gallery  

2. Select the Using the Report Wizard option, and select the Mail Label report type.  

3. Click OK to open the Mailing Labels Report Creation Wizard window.  

4. Navigate to and select the following tables by double-clicking the table name: Order_Badge and 

Order_Meet  

5. In the links window, delete the Delegate link if it exists.  

6. Click Next 

7. Add the following fields by double-clicking the field name: FULL_NAME, TITLE, COMPANY, INFORMAL, 

CITY and STATE_PROVINCE 

8. Click Next  

9. Select the Name Badge (Avery 5395)  

10. Click Next  

11. Select Order_Meet.MEETING in the Record Selection area and click the Add icon 

12. Click the drop-down list, and select is equal to.  

13. Click the second drop-down list and select TECHX.  

 

 
14. Click Finish to update the data and preview the report.  



NiUG Asia Pacific Discovery Conference 2009  Discover the Secret 

Crystal Reports for Beginners (Workshop)   11 

15. Save the report as Workshop10.rpt. Your report should be similar to the following example.  

 

 

Workshop 11. Linking Tables - II 
In this workshop you will create a report using a left outer join to join to include all records in the Activity 

table and the Subscriptions table.  

 

1. Select File > New to open the Crystal Reports Gallery  

2. Select the Using the Report Wizard option, and select the Standard report type.  

3. Click OK to open the Standard Report Creation Wizard window.  

4. Navigate to and select the Activity and Subscriptions tables.  

5. In the Link area, remove all links expect the Activity.ID and Subscriptions.ID link and click Next.  

6. In the fields area, insert the following fields Activity.ID, Activity.MEMBER_TYPE, 

Subscriptions.PRODUCT_CODE 

7. Click Next  

8. In the Group area, select the Activity.ID, Activity.MEMBER_TYPE, and Activity.ACTIVTY_TYPE fields 

9. Click finish. 

10. Click the Select Export icon 

11. Select Activity.MEMBER_TYPE 

12. Select is equal to from the drop-down list.  

13. Select A from the second drop-down list.  

14. Click OK.  

15. Right-click on the ID field, and select Format Field .  

16. Enable the Suppress If Duplicated option on the Common tab, and click OK.  

17. Right-click on the Activity Type field and select Format Field.  

18. Enable the Suppress If Duplicated option on the Common tab and click OK.  

19. Click the Refresh icon on the Standard toolbar. Your report should look similar to:  

 

 
 

20. Click on the database expert icon  

21. Select the Links tab  

22. Select the link between Activity.ID and Subscriptions.ID and click Link Options  

23. Under Join Type select the Left Outer Join option and click OK. Click prompts you to then refresh the 

report data.  

24. Click OK  

 



NiUG Asia Pacific Discovery Conference 2009  Discover the Secret 

Crystal Reports for Beginners (Workshop)   12 

 
 

As the left outer join was selected the report now includes all records regardless if data existed in the 

Subscriptions table.  

 

 
25. Save the report as Workshop11.rpt 

 

Using Parameter Fields 

Workshop 12. Create a parameter report to locate an outstanding invoice  
In this workshop we will create a report with the customer’s details and any outstanding invoices for a 

particular amount.  

 

1. Select File > New to open the Crystal Reports Gallery  

2. Select the Using the Report Wizard option, and select the Standard report type.  

3. Click OK to open the Standard Report Creation Wizard window.  

4. In the Data window, navigate to and select the Name and Invoice tables  

5. Click next twice  

6. In the Fields window, select the following fields: Name.ID, Name.FULL_NAME, Name.CITY, 

Invoice.DESCRIPTION, Invoice.BALANCE  

7. Click Next  

8. In the Grouping Window, select Name.ID  

9. Click Next  

10. In the Summaries window, verify the Invoice.BALANCE are in the summarized area.  

11. Click finish 

12. Click on the Design tab.  

13. Right-click on individual column headings and select Edit Text Object. Rename the column headings as 

follows using initial caps: Id, Name, Suburb, Invoice Description and Outstanding Balance.  
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14. Suppress the ID field in the detail section  

15. Select Can Grow on the Invoice Description  

16. Click the Field Explorer icon on the Standard toolbar to open the Field Explorer window.  

17. Select Parameter Fields.  

18. Click the New icon on the Field Explorer window to open the Create Parameter Field window.  

19. Enter Balance in the Name field  

20. Add “Enter the outstanding balance” in the Prompting Text Field  

21. Select Currency from the Value Type  

 
 

22. Select OK  

23. In the Record Selection window, double-click Invoice.BALANCE to add it to the Filter Fields area.  

23.1. Click the drop-down list and select is equal to  

23.2. Click the second drop-down list and select {?Balance} 

 
 

24. Select OK  

25. The new parameter field ‘Balance’ will prompt you for a balance amount – enter 10.  

26. Only the records with a balance of 10 are displayed  

 
 

27. Save your report as Workshop13.rpt 

 

 

 

This completes the workshops for the Crystal Reports for Beginners – we hope you got a few tips and tricks! 

Please remember to complete the Evaluation Form.  

 

Thank you,  

 

Greg Norris & Michelle Lelempsis 

 

 

 


